Springen naar inhoud


WPF

Crystal Report



  • Log in a.u.b. om te beantwoorden
Er zijn 4 reacties in dit onderwerp

#1 Ludi

Ludi

    Professional Developer

  • Leden
  • PipPipPipPip
  • 349 berichten
    Laatst bezocht 21 sep 2017 14:37

Geplaatst op 21 mei 2016 - 00:23

Hallo,

Ik heb een probleem met Crystal Report,

Ik heb geinstalleerd Window 10, Visual Studio 2015, Framework 4.5.2., CRforVS_13_0_16.

Als het rapport nu word doorgegeven aan Crystal report krijg ik de melding;

"ArgumentNullExeption was unhandled"
"Value cannot be null"

Dit kwam voorheen niet voor en ik weet niet waar ik het moet zoeken. Ik weet dat dit misschien weinig informatie is maar de alle rapporten die het voorheen het wel deden doen het nu niet meer.
Indien ik ga zoeken op internet naar een oplossing dan wordt het niet echt duidelijk.

Kan iemand me verder helpen. Indien je meer info nodig hebt dan wil ik die, indien mogelijk, geven.

Ik heb er zelf een donatie aan VBBE voor over.

#2 pascalbianca

pascalbianca

    Webmaster/Admin

  • Webmaster
  • 4382 berichten
    Laatst bezocht 27 sep 2018 16:55
  • LocatieSusteren, Nederland, Midden Limburg.
Inzender

Geplaatst op 22 mei 2016 - 22:07

En in welk stukje code krijg je die precies?

#3 Ludi

Ludi

    Professional Developer

  • Leden
  • PipPipPipPip
  • 349 berichten
    Laatst bezocht 21 sep 2017 14:37

Geplaatst op 22 mei 2016 - 22:25

CrystalReportsViewer1.ViewerCore.ReportSource = crReportDocument

Hierna verlaat hij de sub en dan komt hij met deze melding.

#4 pascalbianca

pascalbianca

    Webmaster/Admin

  • Webmaster
  • 4382 berichten
    Laatst bezocht 27 sep 2018 16:55
  • LocatieSusteren, Nederland, Midden Limburg.
Inzender

Geplaatst op 24 mei 2016 - 18:29

Kijk eens hiernaar LINK , misschien helpt dit.

#5 Ludi

Ludi

    Professional Developer

  • Leden
  • PipPipPipPip
  • 349 berichten
    Laatst bezocht 21 sep 2017 14:37

Geplaatst op 24 mei 2016 - 22:31

Alle eerst bedankt voor het zoeken/meedenken.

Eigenlijk is het te gek voor woorden dat er iets wordt veranderd zonder dat 'bekend' is maar ik het gevonden

CrystalReportsViewer is de viewer om een rapport dat gemaakt is door Crystal Rapport gemaakt zichtbaar te maken ongeacht de versie van Crystal Report.
Aan de viewer is een veld toegevoegd wat gevuld moet zijn CrystalReportsViewer1.Owner. Dit veld heeft 'normaal' de waarde NULL. Die mag niet dit moet gevuld zijn.

CrystalReportsViewer1.Owner = Me

Hierna kun je elk rapport weer openen.
Hiermee is nog niet alles opgelost. Indien het rapport geladen wordt en je connectie hebt met de database blijkt dat crReportdocument.RecordSelectionFormula anders met de informatie om te gaan.
In deze crReportdocument.RecordSelectionFormula staat b.v  

(  {MT_CrewAni.REC_DELETED} = 0  AND  {MT_Crew.MT_PlantID} = {?Pm-ST_Plant.Plant_Id}  )  

Crystal Report 'lees' deze regel/record anders en meldt onbekend veld. Iets wat niet kan wat we hebben wel verbinding met de database.

Dus dat moet nog gezocht worden





Ook met taq WPF voorzien

0 gebruiker(s) lezen dit onderwerp

0 lid(leden), 0 bezoeker(s), 0 anonieme gebruikers

Inloggen


[WPF] Untitled 1

Met dank aan J├╝rgen voor de jarenlange inzet van visualbasic.be (anno dec 2000)
Met dank aan Mike en Ronneke voor de jarenlange inzet van vbib.be (anno dec 2010)
Met dank aan PascalBianca voor de jarenlange inzet van vbib.be (anno dec 2016)