Springen naar inhoud


PI Solved

Interfaces Eth0 Static Ip Address

Pi IP Static

  • Log in a.u.b. om te beantwoorden
Er zijn 10 reacties in dit onderwerp

#1 Luckie64

Luckie64

    Senior Developer

  • Leden
  • PipPipPip
  • 206 berichten
    Laatst bezocht 31 aug 2016 16:55

Geplaatst op 15 december 2012 - 17:15

Ik gebruik vaste IP-adressen.
Ik stel voor als interfaces:
Code:
auto eth0
iface eth0 inet static
address 192.168.1.55
netmask 255.255.255.0
gateway 192.168.1.1

Wat is verkeerd, ik kom niet op internet?

#2 pascalbianca

pascalbianca

    Webmaster/Admin

  • Webmaster
  • 4382 berichten
    Laatst bezocht 26 nov 2018 06:49
  • LocatieSusteren, Nederland, Midden Limburg.
Inzender

Geplaatst op 15 december 2012 - 17:43

Als je dit in je terminal typt wat ipadres krijg je?
Code:
sudo ip addr show
Misschien een snapshot zodat ik kan zien wat verkeerd is.

#3 Luckie64

Luckie64

    Senior Developer

  • Leden
  • PipPipPip
  • 206 berichten
    Laatst bezocht 31 aug 2016 16:55

Geplaatst op 15 december 2012 - 18:13

sudo ip addr toont:
Code:
1: lo: mtu 16436 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
2: eth0:
mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether b8:27:eb:49:b1:13 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.55/24 brd 192.168.1.255 scope global eth0



#4 pascalbianca

pascalbianca

    Webmaster/Admin

  • Webmaster
  • 4382 berichten
    Laatst bezocht 26 nov 2018 06:49
  • LocatieSusteren, Nederland, Midden Limburg.
Inzender

Geplaatst op 15 december 2012 - 18:59

Probeert u via uw pc verbinding maken met de Raspberry of probeer je met de Raspberry op internet te komen?
Ik vraag dat omdat ik zie dat uw Raspberry adres op IP-adres 192.168.1.55 poortnummer 24 zich bevind.

De volgende afbeelding ziet u hoe het eruit ziet op de Raspberry hier.:
Bijlage  rasp_ipadrress.png   34,14K   7 downloads

#5 Luckie64

Luckie64

    Senior Developer

  • Leden
  • PipPipPip
  • 206 berichten
    Laatst bezocht 31 aug 2016 16:55

Geplaatst op 15 december 2012 - 20:21

lokaal netwerk werkt, maar internet wil niet werken!
poort nummer 24 ??? ik heb die poort geforward!
Probleem gateway voor internet!

#6 pascalbianca

pascalbianca

    Webmaster/Admin

  • Webmaster
  • 4382 berichten
    Laatst bezocht 26 nov 2018 06:49
  • LocatieSusteren, Nederland, Midden Limburg.
Inzender

Geplaatst op 15 december 2012 - 20:32

Ik heb een tutorial hier over gevonden wel in het Engels , maar ik denk dat dit je probleem hopelijk oplost.
Veranderd het ip adres in de tekst naar het ip adres van jou uiteraard ;)

Citeren

By default the Raspberry Pi is set up to obtain an IP address from your wired or wireless network automatically. This method of obtaining an IP address is called referred to a dynamic IP or DHCP. The IP address for your Raspberry Pi is much like a house address. Imagine that a postman needs to deliver a package. He will read the address on the package and deliver it to the house number, in a street and in a particular area. When information is sent to your Raspberry Pi it needs to know which Raspberry Pi to send it to. Your Raspberry Pi must have an IP address so that it can receive this information. An IP address looks something like this.
Code:
192.168.100.1
10.10.1.1
This type of IP address is called IPV4. IPV6 is now available but we will be using IPV4 in our examples. You will also want a static IP address if you want to connect to your Raspberry Pi. The DHCP method will change your Raspberry Pi’s IP address almost every time you restart which can cause a problem if you are connecting to it using an IP address of 192.168.100.1. At the next reboot, it may change it to 192.168.100.2. In order to do this we need to edit the interfaces file. Enter the following command in the terminal window.
Code:
$ cat /etc/network/interfaces
This will list the network interfaces available.


iface lo inet loopback
iface eth0 inet dhcp


This file currently reads ‘iface’ meaning interface followed by ‘eth0’ which is you’re the built in network connection on your Raspberry Pi. Next we have ‘dhcp’ which means that we want to use DHCP to obtain an IP address.
Let’s edit the following file so we can use a static IP address.
Enter the following command into the terminal window.
$ sudo nano /etc/network/interfaces
This will allow you to edit the file using nano.  Change the line that reads
Code:
iface eth0 inet dhcp
to
Code:
iface eth0 inet static
Below this line enter the following.
Code:
address 192.168.100.1
netmask 255.255.255.0
network 192.168.100.0
broadcast 192.168.100.255
gateway 192.168.100.254
I have used my network settings but you will need to find out your network settings of your own network. I will list the main points in this file. The IP address of 192.168.100.1 is the address I am giving the Raspberry Pi. The network is the network identification that we are using and the gateway is 192.168.100.254. The gateway is important and in most cases will always point to your firewalls, switch or routers IP address. All traffic from your Raspberry Pi will exit your network via the gateway.
Assuming you have used your own network settings and they are correct, you will need to restart the Raspberry Pi.
Enter the follow
Code:
$ sudo reboot
Your Raspberry Pi should now have a static IP address. To test this log back into your Raspberry Pi and at the terminal enter
Code:
$ ifconfig
You should see a line that reads
eth0 Link ………
inet addr:192.168.100.1 ……..

The ‘inet addr’ should be the IP address that you have assigned to your Raspberry Pi. To confirm that this is true you should ping your Raspberry Pi from another PC or Raspberry Pi. If you ping the IP address you have assigned to your Raspberry Pi and you get a reply then everything worked as planned. Note that the Raspberry Pi or computer you are pinging from must be on the same network range. For example your PC’s IP address must be 192.168.100.2, 192.168.100.3, 192.168.100.4 and so on.
You can also ping your gateway from your Raspberry Pi to check that the Raspberry Pi being recognised on your network.
Code:
$ ping 192.168.100.254
Remember to replace any network IP addresses with your own network settings.


#7 Luckie64

Luckie64

    Senior Developer

  • Leden
  • PipPipPip
  • 206 berichten
    Laatst bezocht 31 aug 2016 16:55

Geplaatst op 15 december 2012 - 20:59

Sorry Pascal, dat heb ik al honderd keer geprobeerd en ik stop nu.
Dit is zeer triest, de gehele namiddag heb ik geprobeerd op internet te komen en het werkt nog steeds niet.
Mijn eerste indruk van de Raspberry is helemaal niet whow, je moet teveel doen om iets aan het werk te krijgen.

#8 pascalbianca

pascalbianca

    Webmaster/Admin

  • Webmaster
  • 4382 berichten
    Laatst bezocht 26 nov 2018 06:49
  • LocatieSusteren, Nederland, Midden Limburg.
Inzender

Geplaatst op 15 december 2012 - 21:08

Raar, ik heb nergens last van gehad.
Ik plugde de internet kabel erin en het werkte direct.
Als je nu probeerd zonder statische ip adres , werkt het dan wel?

#9 pascalbianca

pascalbianca

    Webmaster/Admin

  • Webmaster
  • 4382 berichten
    Laatst bezocht 26 nov 2018 06:49
  • LocatieSusteren, Nederland, Midden Limburg.
Inzender

Geplaatst op 15 december 2012 - 21:18

Misschien een rara vraag maar welk soort router gebruik je? Merk, type enz.

#10 pascalbianca

pascalbianca

    Webmaster/Admin

  • Webmaster
  • 4382 berichten
    Laatst bezocht 26 nov 2018 06:49
  • LocatieSusteren, Nederland, Midden Limburg.
Inzender

Geplaatst op 16 december 2012 - 16:49

Ik heb een pm ontvangen van Luckie64 dat zijn p;robleem is opgelost.
Hij heeft het zo opgelost.:

Citeren

Plaats dit in /etc/resolv.conf:
Code:
nameserver 192.168.1.1
Maar bij opnieuw opstarten keert de Raspberry Pi terug naar zijn oude ip.
Het probleem is dat de netwerk-manager dit door te rebooten doet!
Ik zet de onderstaande code in de terminal, zodat dat bestand niet kan worden aangepast:
Code:
sudo chattr +i /etc/resolv.conf
Na herstart werkt de lan verbinding nu!


Dus thx Luckie64 voor uw oplossing, ik zal dit ook in het How to sectie zetten bij>> How Using A Static Ip Address?

#11 Luckie64

Luckie64

    Senior Developer

  • Leden
  • PipPipPip
  • 206 berichten
    Laatst bezocht 31 aug 2016 16:55

Geplaatst op 19 april 2013 - 22:56

Ik wou mijn nameserver wijzigen en kreeg geen toegang na lang zoeken ben ik er achter gekomen met  :


sudo chattr -i /etc/resolv.conf  

nameserver wijzigen

sudo chattr +i /etc/resolv.conf





Ook met taq PI Solved, Pi, IP, Static voorzien

0 gebruiker(s) lezen dit onderwerp

0 lid(leden), 0 bezoeker(s), 0 anonieme gebruikers

Inloggen


[PI Solved] Untitled 1

Met dank aan Jürgen voor de jarenlange inzet van visualbasic.be (anno dec 2000)
Met dank aan Mike en Ronneke voor de jarenlange inzet van vbib.be (anno dec 2010)
Met dank aan PascalBianca voor de jarenlange inzet van vbib.be (anno dec 2016)